Please update your Amasty Product Feed extension

Hello to Amasty customers! Please read this post till the end if you’ve bought our Product Feed extension for Magento 1.

We’ve detected a vulnerability, which allowed unauthorized access to your Magento files in your current Product Feed version.

The problem is successfully fixed in the latest 3.3.4 version, which is available in your customer account.

Immediate updating to the latest version is strongly recommended for your data security.

If your support period is over, please submit a request to our support team and you’ll get the updated package for free.

We are deeply sorry for this issue, and we did our best to roll out the fixed update as soon as we could. This case has taught us a lot when it comes to advanced extensions security and testing, and we will definitely think over the details of this case to avoid any similar scenarios in the future.

Amasty team continues working on Magento 1 & 2 extensions improvements to provide you with the safest and the most effective solutions.

Thanks for your patience and understanding!